Announcement

Collapse
No announcement yet.

Slight miss/Backfire problem??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slight miss/Backfire problem??

    99 TLR. Has a new fuel pump. “New” used Throttle body injection assembly. Bike starts right up and sounds good but randomly has a miss/backfire it will run for awhile then it might backfire out the throttle body and die. It may run all day with just a miss. I tried to upload a video but it won’t let me. No fault codes

  • #2
    mine backfires every time I ride it. It's pretty much an inherent thing with V-Twins. Every make I've ever owned backfired to some extent through the intake. It shouldn't back fire constantly and doing it enough to make it stall isn't normal. My TLR has been know to backfire in the intake and blow the throttle body out of the intake boot. You might want to check and see if its's all the way in the boot and there are no air leaks.

    Comment


    • #3
      Back firing from the TB's is not inheritant of the TLs. It is not normal. Do a search on the forum and you'll find it is an issue that can be fixed.

      I would highly suggest the both of you to find how to sync your throttles, check your tps and look for vacuum leaks.
      Brainless AT earthling DOT net
      "Take 2 plugs off your Gixxer and it'll sound the same"

      *IMWO = In My Worthless Opinion
      Q2 and Q4's mod list and Albums

      History of Q2

      Q1 Build thread
      Q4 build thread

      Installing Brainless' +Mod Kit -- (Where to buy)
      Starter Relay/Solenoid CONNECTOR Replacement -- (Where to buy)

      Comment


      • #4
        Alright guys. I’m still struggling with the bike and the excessive tapping noise and overall just not running right. A buddy of mine thought the Decomp arm would be the problem so he removes the arms after I seen people were doing it and it didn’t change anything. Should I leave them off or put them back on? When I started it, it will run and idle, if I crack the throttle hard it will blow flame out of the front throttle body and a little bit of smoke out of the right exhaust. It was off for about a half hour and I decided to look at the intake valves through the TB’s I couldn’t see anything noticeable but on the front throttle body when I opened the butterfly there was a shit ton of smoke/Steam. I had to blow it out a couple times to see the valves. I also noticed when I told my buddy to top of the oil he put too much in it and it’s completely covering the site glass. Tomorrow I’m gonna tear it down tomorrow and start from scratch. Check all the timing, do a leak down test, Sync the Throttle body’s since I put a “new” used throttle body assembly on it. And check the valve clearances. When I check the clearances, in what angle does the cams need to be sitting. TDC? Or where. Any help would be appreciated. If there’s any other thoughts you may have please let me know. Also when I sync the Throttle body’s is their a certain vacuum pressure they should read or does it even matter as long as they are the same!
        Thanks guys

        Comment


        • #5
          Originally posted by KBS3251 View Post
          Alright guys. I’m still struggling with the bike and the excessive tapping noise and overall just not running right. A buddy of mine thought the Decomp arm would be the problem so he removes the arms after I seen people were doing it and it didn’t change anything. Should I leave them off or put them back on? When I started it, it will run and idle, if I crack the throttle hard it will blow flame out of the front throttle body and a little bit of smoke out of the right exhaust. It was off for [snip]
          Ok. One's enough. No need to spam everyone. This is a small community and with the proper title you'll get the right pple to answer.
          Brainless AT earthling DOT net
          "Take 2 plugs off your Gixxer and it'll sound the same"

          *IMWO = In My Worthless Opinion
          Q2 and Q4's mod list and Albums

          History of Q2

          Q1 Build thread
          Q4 build thread

          Installing Brainless' +Mod Kit -- (Where to buy)
          Starter Relay/Solenoid CONNECTOR Replacement -- (Where to buy)

          Comment

          Working...
          X