Announcement

Collapse
No announcement yet.

Help with clutch springs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with clutch springs

    I put in the Barnett springs in today and when I went to start and run the Tiller the Neutral light was on even tough the bike was in first gear, also when I tried to ride it in first with the neutral light on it semmed to sputter or slip, do I need to do anything else with these srpingsI thought it was pretty straight forward, do I need to torque the new springs with some tool? Any help would be appreciated.
    1999 B/W TLR, Yosh RS Full Exhaust, K&N Filter, Undertail, Zero Gravity Screen, Barnett springs, Tre, Pair Valve Mod.

  • #2
    :dunno, replacing the springs should have had no effect except give you a heavier clutch lever feel and make the clutch less prone to slipping.

    Try a bleed of the clutch line too.

    It might be possible the cluch is now not fully disengaging and working the shifter drum harder, if it was in 1st with the neutral light on, it should have came good after the first shift, did it?

    Also the GPS is located just behind the clutch basket, you didn't give it a whack or damage it did you? By rights you shouldn't have been near it, if you only changed the springs over, did you disassemble the clutch at all?


    You should have used a torque wrench and loctite on the spring bolts, you can get away with doing it by feel, but they aren't very strong bolts and don't need a lot of torque on them to snap one.
    "I spent most of my money on Scotch, women and cigarettes. The rest I just wasted"

    Comment


    • #3
      It didn't come good after the first shift, I wasn't near the clutch basket, I just replaced the springs one by one, What are the torque settings for those bolts? Thanks for your help.
      1999 B/W TLR, Yosh RS Full Exhaust, K&N Filter, Undertail, Zero Gravity Screen, Barnett springs, Tre, Pair Valve Mod.

      Comment


      • #4
        Common Torque specs

        Changing the springs one by one should have not affected anything. I don't know about the neutral light being on in 1st, is it only on in 1st or 1st and neutral or all gears?
        "I spent most of my money on Scotch, women and cigarettes. The rest I just wasted"

        Comment


        • #5
          Neutral on all gears.
          1999 B/W TLR, Yosh RS Full Exhaust, K&N Filter, Undertail, Zero Gravity Screen, Barnett springs, Tre, Pair Valve Mod.

          Comment


          • #6
            I'm I supposed to change them on neutral or something?
            1999 B/W TLR, Yosh RS Full Exhaust, K&N Filter, Undertail, Zero Gravity Screen, Barnett springs, Tre, Pair Valve Mod.

            Comment


            • #7
              Sound like you might have crushed, crimped, damaged the loom while whipping the fairings on or off, pull the fairing off again and check the cable coming out of the gearbox, the one the TRE is plugged into.

              You can change the spings in any gear you want.
              "I spent most of my money on Scotch, women and cigarettes. The rest I just wasted"

              Comment


              • #8
                Check the conection and cables
                Originally posted by TLCURT
                Because TL's fucking rock.

                It's a cult thing...to own one is to love one.

                Comment


                • #9
                  I did crush, crimped and or damaged the loom.
                  But on the bright side, these things can be fixed. You guys rock especially SteveTLS: you are the man. Thanks.
                  1999 B/W TLR, Yosh RS Full Exhaust, K&N Filter, Undertail, Zero Gravity Screen, Barnett springs, Tre, Pair Valve Mod.

                  Comment

                  Working...
                  X