Announcement

Collapse
No announcement yet.

not a tl but needs help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • not a tl but needs help

    My stepson has a 95 cbr600 it starts fine but when it heats up it starts to pull back and miss fires
    any help or suggestion would be great
    i know the main problem is it has 2 to many pistons but for some reason he likes it that way a fault i think he gets from his father
    sigpic

  • #2
    Re: not a tl but needs help

    Renew spark plugs and try again.

    Comment


    • #3
      Re: not a tl but needs help

      I had a 96 cbr and i had to clean the carbs at least once a year. In fact i bought cheap it cause it ran like crap and the carbs were filthy. After plugs that would be my next step.
      Looking for ETI fuel Cell or carbon bimota tank, and a rear seat for the TLR... PM me with those items.

      Comment


      • #4
        Re: not a tl but needs help

        Originally posted by rivnrev View Post
        I had a 96 cbr and i had to clean the carbs at least once a year. In fact i bought cheap it cause it ran like crap and the carbs were filthy. After plugs that would be my next step.
        Funny...I bought a new 96 F3 and installed a yosh full duplex and Factory stage 3 kit....carbs HAD to be done every year or else ran like poop. Liked to foul out the plugs to boot.

        Comment


        • #5
          Re: not a tl but needs help

          cheers guys i'll do both sand see what happens
          sigpic

          Comment

          Working...
          X