Announcement

Collapse
No announcement yet.

Crisis Averted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Crisis Averted

    Well a week or so ago I noticed a very loud pinging in my motor from 4 to 7k under load or just revving. I was a lot louder than in normal ticking that I have heard since purchasing the bike last year. I had just shimmed my valves so that wasn't the case. I was sure it was a big end bearing but after dropping my oil yesterday and pulling my sump plug I was very happy to find no metal shavings present. The weird thing is that once I replaced the oil the noised went back to the normal tick that I am use to. I change my oil religiously at 3k but I have been using Suzuki Synthetic Racing oil, but I switched to Amsoil synthetic and I believe this is what I will continue to use from now on.

    I am just glad it wasn't a Big end bearing.

    On another note I think that this is one of the most informative forums I have been a member of and without all the Drama that happens on so many other forums...It is nice to find one such as this.

    Thanks guys for all of the insight ito these unique bikes we love.
    Originally posted by evl tvn
    I'm on top of Pete, no worries
    ^^^

  • #2
    Re: Crisis Averted

    glad to hear it
    and your right, this place tops the other forums where its near impossible to get an answer other than USE THE SEARCH BUTTON

    Comment


    • #3
      Re: Crisis Averted

      please use the search feature next time to resolve this.
      .sigpic
      "Use the present, create the future" -Pablo.

      Comment


      • #4
        Re: Crisis Averted

        Lmao...
        Originally posted by evl tvn
        I'm on top of Pete, no worries
        ^^^

        Comment


        • #5
          Re: Crisis Averted

          yep the sites awesome. a resource for all tl owners, gotta keep the thumpin alive.

          Comment

          Working...
          X