Announcement

Collapse
No announcement yet.

new owner

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • new owner

    i just picked up in a trade deal for a 98 suzuki tl1000s. not a bad looking bike and looks like it will be fun to drive. it does have a strating problem with it, and i was wondering if i could get some tips on it.
    it cranks over good until it kills the battery, just wont start. any ideas would be helpful. i was thinking it could be the fuel pump aint kicking on. cause i have a 06 gsxr 1k and when i turn the key you hear that one kick on. would this be simular.and if not what do you think it might be. any help is greatful.

    i did think about just getting rid of it but it is growing on me. whats your guys opinions...

  • #2
    Re: new owner

    Try charging the battery and new plugs.

    Then try again.
    If you can get a steady idle TPS and TB sync.

    You can check the TPS setting via "dealer mode" on the dash display, and adjust if necessary. Sync the throttle bodies at the same time too.
    ************************************************** **************************************************

    My bike mod list - Click here

    Comment


    • #3
      Re: new owner

      Yes, you should hear the pump prime like your other bikes, so start looking there.

      You can download the manual from the file vault.

      You can join for $10 a year.

      Where are you located?
      Vanzuki.com - Click the banner below, to see what I have for your bike.

      Comment


      • #4
        Re: new owner

        Originally posted by vandriver View Post
        Yes, you should hear the pump prime like your other bikes, so start looking there.

        You can download the manual from the file vault.

        You can join for $10 a year.

        Where are you located?


        This is one of the best communities on the entire net, no BS. Any and all questions will get answered with a minimum of drunken gibberish.

        +1 on downloading the service manual from the file vault, has more info than you'll likely need.

        Also +1 on paying the $10.00 a year for a paid memebership to support Rob and his efforts to keep the site up. The first time a seasoned TL guru helps you from throwing one wrench, that's worth $10.00 right there.

        You don't have to pay, and no one will judge you, or give you less help if you don't... but if you keep the TL... it's $10.00 a year.

        If you stick around though... you'll likely sell your families to buy all the goodies on here... I know I did. You have been warned
        sigpic

        Comment


        • #5
          Re: new owner

          Do you have a money tree If not, pay no attention to Van and definitely dont look at any of his group buys. But seriously, Im with Van on all counts. Download the manual and trouble shoot. If you havent done so allready, check your tos(tip over switch). Its mounted on the bottom of your tank. If that is positioned incorrectly, I believe your fuel pump gets powered down.

          Comment


          • #6
            Re: new owner

            +1 on the tip over switch or possibly the kick stand kill switch, if you fossick down around the kick stand you'll find it, try testing that !

            Comment


            • #7
              Re: new owner

              Welcome by the way !

              Comment


              • #8
                Re: new owner

                Welcome.
                - If you find this site useful kick us a few bucks. <a href="http://www.tlplanet.com/forums/billspaypal.php"><b><font color="blue">Tip cup</font></b></a>
                - Want to help support the Planet? <a href="http://www.tlplanet.com/forums/payments.php"><b><font color="blue">Subscribe</font></b></a>

                Comment


                • #9
                  Re: new owner

                  Welcome aboard, i've only been here 1 day and already looks like ive spent over 300 lol, van's pressure plate, clear cover. sorting it all soon. lol you have been warned. : )
                  if its not broken MOD it

                  Comment

                  Working...
                  X