Announcement

Collapse
No announcement yet.

pc3 advice.....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pc3 advice.....

    Just picked up a picked up a power commander 3, its all fitted and I've had a play with the maps, the only problem is I can't get the pump actorvator running. Would it help if I up dated the firmware and can that be done on the bike while its running?

    Cheers
    Thats the great thing about forums, for the 10% of useful information you have to have the 90% of shit that goes with it...

  • #2
    Re: pc3 advice.....

    far as i know if you have a laptop you can download it while its on the bike. i did mine before i fitted it to get it started with a basic map and updated firmware from the web site. just need a dyno run when im ready to tune it fully. : )
    if its not broken MOD it

    Comment


    • #3
      Re: pc3 advice.....

      Thanks, i don't have the power cable? or i would of done it off the bike.
      Thats the great thing about forums, for the 10% of useful information you have to have the 90% of shit that goes with it...

      Comment


      • #4
        Re: pc3 advice.....

        Originally posted by dento33 View Post
        Just picked up a picked up a power commander 3, its all fitted and I've had a play with the maps, the only problem is I can't get the pump actorvator running. Would it help if I up dated the firmware and can that be done on the bike while its running?

        Cheers
        If your are talking about the accelerator pump feature, you need to install it. There is the program on the disc they sent you, or you can go on their website and download it. Once turned on with that program you can then tune it with the normal software.
        Mike Rock
        NESBA #506 '98 TLR
        American cycle performance MRP motorsports

        Comment


        • #5
          Re: pc3 advice.....

          Thank you for your reply, would this be why the bike runs like a bag of shit after i installed the pc3?!?!?
          Thats the great thing about forums, for the 10% of useful information you have to have the 90% of shit that goes with it...

          Comment


          • #6
            Re: pc3 advice.....

            Originally posted by dento33 View Post
            Thank you for your reply, would this be why the bike runs like a bag of shit after i installed the pc3?!?!?
            It might have the wrong map in it. Or it could be the PC is bad. A few have posted about theirs going bad. The accel pump feature shouldn't cause it to run bad, unless you have it turned on and adjusted wrong. Try removing the PC and see how it runs. If it runs decent, I would try to find a closer map to what you need, and if that still doesnt work. I would try to figure out if it took a dump....
            Mike Rock
            NESBA #506 '98 TLR
            American cycle performance MRP motorsports

            Comment


            • #7
              Re: pc3 advice.....

              Well ive unplugged the pc and the bike goes back to normal..the bike while the pc is plugged in starts and run fine then seems to go down hill as you ride it, also when i turn my indicator on to turn it flashed fast as if there was a bad earth??
              ..everything seem done up though?
              I'll have a play tomorrow and get back to you.

              Cheers
              Thats the great thing about forums, for the 10% of useful information you have to have the 90% of shit that goes with it...

              Comment


              • #8
                Re: pc3 advice.....

                O.k, now i have unplugged the pc and went for a longist ride today..the bike idols and runs ok but now and again then now seems to be abit jolty when i excelerate (when the pc first power up the bike wouldn't start, just kept turning over??) could the blip in power be the plugs need changing? I'm going for a weekend away next week so i'll sort the pc out when i come back get it dyno'd etc. just worried about this blip now and again?

                many thanks
                Thats the great thing about forums, for the 10% of useful information you have to have the 90% of shit that goes with it...

                Comment

                Working...
                X