Announcement

Collapse
No announcement yet.

New to the TL world.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New to the TL world.

    Hey guys and gals, I just got my first TL last week. its a 1997 S. Kinda sucks but I haven't even ridden it yet. went to start it and it fires up and sounds good exhaust wise but She needs some work engine wise. There is a nasty loud click in the engine, trying to track it down and figure out where I should start the tear down. I got the bike as a bonus from work so im not going to complain. Just wanted to say hello and was also wondering if anyone else has ever ran into this problem. Not sure if it is a broken valve spring or what it is.

    OregonTL

  • #2
    Re: New to the TL world.

    TL = Ticks Loudly

    Welcome matey, get on it and ride it
    ************************************************** **************************************************

    My bike mod list - Click here

    Comment


    • #3
      Re: New to the TL world.

      Welcome to the TL world!
      ----------------

      01 TLR undergoing a make over!!( Mark told me to do it!)
      Aprilia SXV 4.5

      Comment


      • #4
        Re: New to the TL world.

        Hey guys, This bike has a dynojet power commander installed. when I removed the power commander the bike wont even start.... WTF?
        Last edited by OregonTL; 10-03-2010, 05:42 PM.

        Comment


        • #5
          Re: New to the TL world.

          Welcome to the Planet and the world of the TL.

          Comment


          • #6
            Re: New to the TL world.

            Originally posted by OregonTL View Post
            Hey guys, This bike has a dynojet power commander installed. when I removed the power commander the bike wont even start.... WTF?
            Are the ECU cables plugged in?
            ----------------

            01 TLR undergoing a make over!!( Mark told me to do it!)
            Aprilia SXV 4.5

            Comment


            • #7
              Re: New to the TL world.

              Yes, I removed the Power commander connectors, and plugged the stock harness back in. the bike doesn't sound like it has spark. Im not sure on this one.. On my aprilia rsvR I have a power chip, when I remove the chip it fires right up.. these power commander things are crazy. I just dont really want to leave it installed.. I believe this bike I just got was a track bike or something. Im not able to talk to the previous owner to aks him any questions so yeah.. this may be fun..

              Comment


              • #8
                Re: New to the TL world.

                Originally posted by OregonTL View Post
                I got the bike as a bonus from work so im not going to complain.
                OregonTL

                Where do you work and how do I get a job there?

                Any pictures?
                1997 Suzuki TL1000S -

                Comment


                • #9
                  Re: New to the TL world.

                  lets just say I legally steal cars. I'm the repo man..

                  OregonTL
                  Last edited by OregonTL; 10-03-2010, 06:18 PM.

                  Comment


                  • #10
                    Re: New to the TL world.



                    Heres a pic..

                    Comment


                    • #11
                      Re: New to the TL world.

                      Originally posted by OregonTL View Post
                      lets just say I legally steal cars. I'm the repo man..

                      OregonTL
                      I use to do something similar to that. I use to tow abandoned cars for OKCPD and hold them until the owner showed to pay tow and storage fees. Most of the time they never showed.
                      My build thread --->http://www.tlplanet.com/forums/showthread.php?t=79793
                      My suspension upgrade --->http://www.tlplanet.com/forums/showthread.php?t=84704
                      Plumbers and Pipefitters L.U. 441
                      SAL/ALR Post 401
                      Wichita, Ks.

                      Comment


                      • #12
                        Re: New to the TL world.

                        If you unplug the power commander and plug that same harness plug into the ECU where you unplugged the other power commander cable, it should fire right up unless you pushed out a pin from a plug or bent a pin. It may not be optimized but it should run. Try cleaning the plugs and starting it again.
                        It's about control skill; this is a motorized dance for joy and not Russian roulette.

                        Comment


                        • #13
                          Re: New to the TL world.

                          Welcome

                          As they have said, the ticking is normal, nothing to be alarmed about. One of the many idiosyncrasies of our old beasts. Gives it character.
                          sigpic

                          Comment


                          • #14
                            Re: New to the TL world.

                            Welcome to the Planet

                            If it starts and runs with the Power Commander installed, leave it in for the time being. Then you can sort out any other issues it may have to make it rideable.

                            Keep in mind, if you really feel the need to remove the PC, then you will likely need to "adjust" the fuel maps by some other means, i.e. a Yosh box, or a Teka box, because the factory settings really weren't that great - especially since you have aftermarket cans on it.

                            What else has been done to it? You'll find out sooner or later.
                            Keep an eye on you wallet. These TLs have a way of prying it open.

                            January 2012 - BBOTM & TLOTM

                            Comment


                            • #15
                              Re: New to the TL world.

                              welcome dont worry about the ticking, least not yet.
                              if its not broken MOD it

                              Comment

                              Working...
                              X