Announcement

Collapse
No announcement yet.

TL100S wont rev over 6500 revs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TL100S wont rev over 6500 revs

    my TL1000 wont rev over 6500 rev's. I have changed the spark plugs and i put injector cleaner in my fuel tank, but still the same problem, i also checked the ECU diagnostics code and it shows c00 which is no fault. Any ideas??

  • #2
    Re: TL100S wont rev over 6500 revs

    Fuel filter or side stand switch.

    Do the fuel pump test out of the manual. Measure how much fuel comes out of the return line / time. If it fails, it's probably the fuel filter.

    Check that the side stand switch mounting bolts are tight and the stand is depressing the plunger all the way.
    "I spent most of my money on Scotch, women and cigarettes. The rest I just wasted"

    Comment


    • #3
      Re: TL100S wont rev over 6500 revs

      What Steve said.

      And welcome.
      "The rifle itself has no moral stature, since it has no will of its own. Naturally, it may be used by evil men for evil purposes, but there are more good men than evil, and while the latter cannot be persuaded to the path of righteousness by propaganda, they can certainly be corrected by good men with rifles."

      Colonel Jeff Cooper, in "The Art of the Rifle"

      Comment


      • #4
        Re: TL100S wont rev over 6500 revs

        what happens when it gets to 6500

        is it only under load or will it not free rev in neutral also

        is this a new problem or have you just bought the bike with it or what else.

        the more info you can provide the more accurate the help can be.
        www.cycleinnovations.com.au

        It never ceases to amaze why people ask for advice then when I give it they either ignore it or argue against it.
        But then I don't know all that much about TL's

        wwjd.......what would jimmy do.

        Comment


        • #5
          Re: TL100S wont rev over 6500 revs

          i checked the stand switch not that, gonna check the filter now.

          it's fairly new, it got worse, used to do it at about 8500rpm and now recently got worse, my fuel consumption also dropped from about 260km per tank to about 170km per tank. I checked revivng it in nuetral seems fine, its only when i ride, when it reaches 6000 / 6500 it seems to stop and just go prprprprprprprprprprp until i change, sometimes when i just hold it at eg. 2500rpm when in nuetral it will idle and seem to dup and rev again like rrrrrrrrrrrrrrrrrrrrrrrrrr dup rrrrrrrrrrrrrrrrrrrrrrrrrrrrr dup rrrrrrrrrrrrrrrrrrrrr when i drive sometimes the bike also will ranmdomly jerk while riding between 3000 and 4000 rpm's.

          Comment


          • #6
            Re: TL100S wont rev over 6500 revs

            might also check ignition leads
            age is a state of mind
            sigpic [IMG]
            ZG dble bbl, ss lines 6pots,Pazzo shorties ROCK!, Penske rear shock Lindman re-worked forks,custom (by me) dual HID Xenon Hi/Lo projectors Ultra-Violet halo's, LED sigs & plate lights, E G hugger,P M cyclone wheels, Rifleman 1/5 throttle,Van's Billet CCC, Galfer wavies, 6spring clutch Van's mod II Clutch plate, PCIII, speedo healer, and more...

            Comment


            • #7
              Re: TL100S wont rev over 6500 revs

              its the fuel filter, i stripped out the fuel filter and brown stuff started coming out out, had to blow real hard into it to get air out the other side, the spare shop was closed so i by-passed the filter for now will get one tommorow, its revs right through 9500revs now . thank you everybody !!!!!!!!!

              Comment


              • #8
                Re: TL100S wont rev over 6500 revs

                You may seriously want to consider doing the external filter mod at this point in time .
                Triumph 1050 Speed Triple

                Wilbers rear shock, Reworked forks Racetech gold valves, Crazy Mofo Rad guard, FP Racing levers, IXIL low pipe .

                TLS naked project

                Rebuilt motor from Sam, 04-06 R1 forks/brakes and wheels, Penske shock and spring + Linderman link, Big bore zorst with Ti Scorpion cans, TLS that needs some loving .

                Comment


                • #9
                  Re: TL100S wont rev over 6500 revs

                  Free reving isolates it from a computer problem.

                  well found
                  www.cycleinnovations.com.au

                  It never ceases to amaze why people ask for advice then when I give it they either ignore it or argue against it.
                  But then I don't know all that much about TL's

                  wwjd.......what would jimmy do.

                  Comment


                  • #10
                    Re: TL100S wont rev over 6500 revs

                    I ditched the stock filter. I bypassed it and installed a glass inline filter I got at napa. It says not to use that filter with FI systems but I havent had any problems with it leaking. the glass cylinder is thick too so i doubt its going to burst or crack easily. Plus I can SEE when my filter is dirty and clean it out or buy a replacement filter element.
                    1998 TLS
                    Lower fairing kit, +MOD, TRE, PCIII, D&D Full System, K&N, Airbox MOD, HIDS 8K, Gunmetal powdercoated rims, Atomic Orange paint.

                    Comment


                    • #11
                      Re: TL100S wont rev over 6500 revs

                      So it says not to use it on a FI system and you used it anyway? I hope for your sake it doesn't burst under the FI pressure.

                      There would be a reason they say not to use their product on a fuel injected system.
                      "I spent most of my money on Scotch, women and cigarettes. The rest I just wasted"

                      Comment


                      • #12
                        Re: TL100S wont rev over 6500 revs

                        Could be that you have a TL100. The 1000's usually rev a bit higher.

                        Jokes aside, good find on the filter. I've replaced mine but haven't opened the old one to see how clogged it was.
                        Originally posted by Rifleman
                        ...I'm more busy then a one legged man at a butt kickin' contest.

                        Comment


                        • #13
                          Re: TL100S wont rev over 6500 revs

                          yes i think thats a good idea to do

                          Comment


                          • #14
                            Re: TL100S wont rev over 6500 revs

                            damn, i have the same problem and still havent found the fix. i was hoping for some insight in this thread. ah well.

                            Comment


                            • #15
                              Re: TL100S wont rev over 6500 revs

                              I had a similar problem also.... It would pull all the way to 6.5k-7k rpms and then fall flat on its face... come to find out there was a split in the rubber hose section inside the tank on the pump cradle. the rubber section between the filter and the pump.
                              1998 TLS
                              Lower fairing kit, +MOD, TRE, PCIII, D&D Full System, K&N, Airbox MOD, HIDS 8K, Gunmetal powdercoated rims, Atomic Orange paint.

                              Comment

                              Working...
                              X